Friday, December 12, 2014

Been a long time since posting but thought I would throw this out there...... DO NOT install
RU8 for Exchange 2010 SP3.  MS just pulled it for a pretty big bug which caused Outlook clients
to not be able to connect with the server after the update.  Not sure how they missed this one in
testing on O365 but MS has been on a real downward spiral with Exchange updates lately.  I'm
holding off on CU7 for Exchange 2013 as well just in case.  YMMV.